COMPANNERO
Главная » 2014 » Октябрь » 13 » Cisco. полезные (часто используемые) команды консоли.
22:57
Cisco. полезные (часто используемые) команды консоли.

 

Горячие клавиши:
Ctrl P (или клавиша вверх) - Повтор предыдущих команд ("шаг назад")
Ctrl F, Ctrl B - Передвижение строки по символу (Назад, Вперед)
Ctrl A - Вернуться в начало строки
Ctrl E - Вернуться в конец строки

show vlan briefпросмотр существующих vlan`ов на свиче
show ip interface brief - просмотр существующих IP интерфейсов на свиче
show interfaces trunk просмотр существующих trunk интерфейсов на свиче
show interfaces switchport просмотр коммутации на интерфейсах свича

show version - Показывает наименование модели циски, версию IOS
show startup-config - Показывает содержимое конфигурации, которая применяется при загрузке. Можно скопировать эти данные в буфер обмена и сохранить в файл в качестве бэкапа конфигурации. Этот файл потом можно просто вставить
Switch>enable - Переход в привелигированный режим. (символ ">" означает режим просмотра)
Switch#config - Переход в режим конфигурирования
Swith#copy running-config startup-config - Cохранение файла загрузки
Swith#copy startup-config running-config - отменяет все сделанные (если были) изменения в конфигурации. То же самое произойдет, если выключить/включить питание (перезагрузить устройство).
Switch(config)#hostname Office - Задать имя Свитча
Swith(config)#no ip domain lo - Отменяет запрос команд в домене (минус тупняк при введённой неверной команде)
swith(config)#int gigabitethernet 0/0
swith(config-if)#no shutdown - Включить порт (shutdown выкл)
swith#sh clock - Просмотр установленной даты и времени.
Swith#clock set 13:30:00 12 may 2014 - Установка времени на Свитче
Swith(config)#clock timezone MSK 4 это название зоны, название временных зон можно найти на сайте: http://www.timeanddate.com/library/abbreviations/timezones/
Switch(config)#int vl1 - Режим конфигурации Vlan 1 ( Vlan по умолчанию конф IP свитча ниже)
Switch(config-if)#ip address 192.168.10.1 255.255.252.0 - Задать IP и маску для vlan.
Swith(config)#interface FastEthernet0/2 - Перейти к конфигу порта №2
swith(config-if)#speed 100 - Переключение скорости на порту #2 (см. выше)
swith#sh ip interface brief - Просмотреть всю конфигурацию IP на портах
swith#write - cохраняет в энергонезависимой памяти все изменения.
swith#show interfaces - показывает количество, параметры, состояние интерфейсов и ещё много разной информации.

swith#sh vlan - Просмотреть Vlan'ы
swith(config)#vlan 733 - Создать Влан 733
swith(config-vlan)#name Internet - Задать имя Влан 733 Internet
swith(config)#no vlan 733  - Удалить vlan 733.

swith(config)#line console 0

swith(config-line)#exec-timeout 1 - Установка таймера аutologof (1 мин.)
 

swith(config)#line console 0
swith(config-line)#history size 10
0 -  Устанавливает буфер для команд в соответствии с переменной (х).

swith#sh clock - Просмотр установленной даты и времени.
swith#sh vlan - Просмотреть Vlan'ы

swith(config)#line console 0

swith(config-line)#exec-timeout 1 - Установка таймера logof
 

swith(config)#line console 0
swith(config-line)#history size 100
-  Устанавливает буфер для команд в соответствии с переменной (х).

swith(config)#ban login `SUPER` - Установка Банера SUPER (Информация при загрузке свитча)
 

_________________________________________________

Учетная запись + пароль (невидимый)

Swith#config

Configuring from terminal, memory, or network [terminal]?

Enter configuration commands, one per line. End with CNTL/Z. >> press Enter >>

Swith(config)#line console 0

Swith(config-line)#password 123456

Swith(config-line)#login

Swith(config-line)#username Manager secret 123456

Swith(config)#login local

Swith(config)#line console 0

Swith(config-line)#login local

_________________________________________________

Добавление в Access List

Swith(config)#access-list 1 permit host 10.1.1.1

Swith(config)#access-list 1 deny any 
Просмотреть Acces List
Swith#sh access-list 1

Standard IP access list 1

permit host 10.1.1.1

deny any

_________________________________________________

 

Добавление Trunk на порт

 

SW1(config)#int fa0/3

SW1(config)#int range fa0/1-- Переход в интерфейс нескольких портов (c 1-го по 3-ий)

SW1(config-if)#swithport mode trunk - Добавляем третий порт в Trunk

_________________________________________________

Назначение порта коммутатора в VLAN:

sw1(config)# interface fa0/1
sw1(config-if)# switchport mode access
sw1(config-if)# switchport access vlan 2

_________________________________________________

Spanning-tree

Switch#show vtp counters - просмотреть настройки VTP
Switch#show interfaces trunk - показать транк на интерфейсе.
Switch#show interfaces fa0/1 switchport - Просмотреть настройки на порту

___________________________________________

DHCP SERVER

Router>en     -     заходим в привилегированный режим
Router#conf t     -     идем в режим глобальной конфигурации
Router(config)#int fa0/1     -     заходим в настройку интерфейса
Router(config-if)#ip address 192.168.1.1 255.255.255.0     -     задаем ip адрес и маску подсети
Router(config-if)#no shut     -     не забываем включить интерфейс
Router(config-if)#exit     -     возвращаемся в режим глобальной конфигурации
Теперь можно настроить DHCP сервер который будет раздавать настройки нашим компьютерам

Router(config)#ip dhcp pool test     -     создадим пул адресов с именем test
Router(dhcp-config)#network 192.168.1.0 255.255.255.0     -     укажем подсеть для которой будут раздаваться ip адреса
Router(dhcp-config)#default-router 192.168.1.1     -     передаем компьютеру параметр default-gateway на наш маршрутизатор
Router(dhcp-config)#dns-server 192.168.1.2     -     можно так же передать параметр dns сервера сети. В нашем случае это 192.168.1.2
Router(dhcp-config)#exit     -     возвращаемся в режим глобальной конфигурации
 В данном случае маршрутизатор будет раздавать адреса начиная от 192.168.1.1 до 192.168.1.254, default-gateway=192.168.1.1, dns-server=192.168.1.2
Часто бывает, что мы хотим раздавать не все ip адреса в подсети и собираемся выделить несколько адресов, что бы задать их статически (чаще всего это относится к серверам). К тому же адрес нашего маршрутизатора 192.168.1.1 и мы не хотим выдавать этот ip адрес кому бы то ни было еще. Предлагаю выделить 10 ip адресов под наши нужды и не раздавать их, для этого произведем некоторый настройки на маршрутизаторе.

Router(config)#ip dhcp excluded-address 192.168.1.1 192.168.1.10     -     мы исключили из раздачи адреса с 192.168.1.1 до 192.168.1.10

____________________________________________________

 

 

 

Категория : IT CROWD | Просмотров : 1227 | Добавил : BatMAn | Теги : команды, Cisco, Циска, comand, консоль, commands, console | Рейтинг : 4.0/1
Всего комментариев : 0
Имя *:
Email:
Код *:
© Copyright Сундучок Compannero. All Right Reserved.